Course Details

Quick Facts

  • Course #PLS3046

Contact Information

This 2-unit course is offered completely online in the Winter quarter. Paralegals are often depended on to coordinate much of the discovery process in civil litigation. Taking on this role requires that paralegals are familiar with and understand e-discovery rules, requirements, and procedures. Students in this course will learn the basic principles of project management, and how to apply these established principles to each phase of the e-discovery process.

New Users – What to Expect:

Click on the “New User? Register” gray box below and enter your contact information to create a new account. The email address and password that you enter will be your username and password for all online courses that you take through our system.  You can log into your course in the future by bookmarking: ce.jfku.edu/public

Next, complete the “Student” information section by providing your license type and number (if that applies to you)

Enter the Billing and Payment information to purchase the course.

Check that you have read the Terms and Conditions, and then click the “Register for Course” gray box.

The webpage will refresh to your course page.  Click “Launch Course” to begin!

Returning Users – How to Access Your Courses:

Please select the “Returning User? Log in” Option. Your e-mail is your username, and your password is what you selected at registration. If you have forgotten, please click ‘Forgot Password?’ and follow the prompts.

You can login to your course in the future by bookmarking this login page: ce.jfku.edu/public

Extensions are available if needed, please e-mail: conted@jfku.edu.

Technical Requirements:

Before you begin an online course, please make sure your computer has a broadband Internet connection. A dial-up connection is not sufficient.

The online courses require that you use the most recent Internet Explorer, Chrome, or Firefox Internet browsers, which you can download from these links: PC/Mac: Chrome (newer Macs only) or Firefox (Macs over 2 years old). Safari is notcompatible.  Adobe Flash player is also required and can be downloaded by clicking here.

Set something in motion with a simple yes.